[[cms:typo3-installation-und-einrichtung]]

Typo3 Installation und Einrichtung

wir gehen von einer Installation auf einen richtigen Webserver aus, es sind aber auch Typo3 Installer-Pakete verfügbar.

  1. Die Webserver-Config für den virtuellen Host + SSL für backend sollte bereits erfolgt sein
  2. die Pakete dummy und source müssen von der Typo3-Installationseite geladen und kombiniert (in einem Verzeichnis entpackt) werden. Alternativ kann man sich die source in ein übergeordnetes Verzeichnis entpacken und anschließen die dummy im webroot entpacken. Setzt man den symlink (typo3_src) anschließend richtig geht es nur noch um die Rechte im webroot (also die entpackten Dateien des dummy-Paketes)
    chown www-data.www-data fileadmin
    cd fileadmin
    chown -R www-data.www-data *
    cd ..
     
    chown www-data.www-data typo3conf
    touch typo3_conf/ENABLE_INSTALL_TOOL
    cd typo3conf
    chown -R www-data.www-data *
    cd ..
     
    chown www-data.www-data typo3temp
    cd typo3temp
    chown -R www-data.www-data *
    cd ..
     
    chown www-data.www-data uploads
    cd uploads
    chown -R www-data.www-data *
    cd ..
  3. wir brauchen noch einen Datenbank-Benutzer für typo3 der entweder das Recht hat Datenbanken anzulegen (globale Rechte) oder einen Benutzer mit Benutzungsrechte und eine leere Datenbank (kann auch über das Install-tool angelegt werden)
  4. dann kann man die Installation starten und dem Assistent folgen
  5. nach der Installation sollte man das Installationsverzeichnis löschen oder wieder einen Schutz in typo3/install/index.php einbauen (z.B. wird kann man ein
    exit;

    in die erste Zeile setzen). Oder man schützt das Verzeichnis mit einer .htaccess-Datei.

  6. wenn man Continue to configure TYPO3 (Recommended). auswählt kann man (und sollte man!!!) das Passwort der Installation ändern (dies wird Verschlüsselt in typo3conf/localconf.php gespeichert).
  7. Ansonsten kann man dem Installationsassistenten folgen

Fehlerbehandlung:

  1. evtl. macht der SafeMode von PHP Probleme, da das Programme ImageMagick außerhalb des safe_mode_exec_dir (in der php.ini) liegen könnte.
    1. Entweder man schaltet den SafeMode aus (geht nicht immer),
    2. schaltet safe_mode_exec_dir = /usr/bin/ an (geht dann meistens erst recht nicht)
    3. oder man kopiert bzw. man legt SymLinks) auf die Dateien: convert, combine bzw. composite und identify in einen erreichbaren Ordner innerhalb des erreichbaren safe_mode_exec_dir an. Dann muss man in der 'localconf.php'' den Pfad dazu ändern.
  2. das gleiche gilt für Sendmail (verschicken für mails), auch dies ist nicht erreichbar. sendmail_path=/usr/sbin/sendmail -t -i
  3. auch open_basedir= könnte ein Problem sein

Als nächstes müssen Seiten erstellt und vor allem ein Typo3-Template (Vorlage) erstellt werden.

Nach der Konfiguration loggt man sich im Backend ein (Seiten existieren noch nicht und ein Template ist noch nicht definiert).

Zugangsdaten (standardmäßig):
Wo? User Passwort
BackEnd Login (Installationsverzeichnis + typo3 anhängen) admin password
Install Tool Passwort joh316